Freepages-Help-L Archives

Archiver > Freepages-Help > 2007-07 > 1185930881


From: "John Cardinal" <>
Subject: Re: [FreeHelp] my table on my page is way down the page HELP
Date: Tue, 31 Jul 2007 21:14:41 -0400
In-Reply-To: <001901c7d3d3$1c1f1df0$0b00a8c0@SueAnnMorrow>


Sue Ann Hornung White Morrow wrote:
> I'm not very great at all the technical terms, I'm even
> pretty dumb about how html works. I get by though and have
> built my website with errors and all kinds of problems. I'm
> managed enough to get by, but this one page is driving me
> crazy. My table is way down on the page and no matter what I
> do I can not get it to where it's suppose to be. It seems
> the more names I add the further down the page it goes. Can
> someone explain to me in laymans terms please because I do
> this by hand and not with any program what is wrong? If I
> can't get it fixed I will have to change the entire site for
> this particular venture. Here is one of the pages. If I can
> get this one fixed, I can fix them all. Thank you in advance
> for any help.
> http://freepages.history.rootsweb.com/~kyborn/draftcardsh.html

Sue Ann,

There are a lot of HTML errors on that page, and some of them are
interfering with the way you want it to look.

The specific error that is causing the contents to move down the page is a
little difficult to describe. I'll try to show you. There are multiple
copies of this HTML code:

<tr>
<div align="center">
<td width="60%" height="20" bgcolor="#AAB3E5">

"TR" starts a row in a table. BUT... it is supposed to contain TD tags only.
In your case, the next content is a DIV. That's an error, and how the
browser deals with the error is unpredictable. In some cases, the browser
pushes the content out of the table. That's what is happening to you.

If you change that statement as follows:

<tr>
<td width="60%" height="20" bgcolor="#AAB3E5" align="center">

That willl help.

Unfortunately, there are many other errors and so it's hard for me to know
that the problem will be solved. It's definitely an error, though, and it
should be fixed. After it's fixed, upload the new version and send another
message to the list. I'll take a look and see what changes.

John



This thread: